Injecting IGP routes into BGP

Posted in NETWORKING/IP ROUTING by edeguzman on October 3, 2007

This is a configuration wherein routes in the routing table is place in the BGP table.
The routes in the BGP table will be advertised to its BGP peer whether its inter-AS or
intra-AS. Below is the configuration.

router eigrp 200
passive-interface s0
network 192.168.1.0
network 192.168.100.0
!
router bgp 200
redistribute eigrp 200
neighbor 192.168.1.226 remote-as 100
!

The configuration shows that I used the EIGRP as my IGP running within the AS 200,
a passive-interface is configured in its process, wherein it means that in the interface serial 0 it will not advertise neither receives updates and it will not even send a hello packet in that interface.

In the BGP process, a redistribute eigrp 200 is configured this will simply redistribute the routes learned via EIGRP into the BGP table. You can see its results by making a show ip bgp, from there you can see the routes of EIGRP that is distributed into the BGP table. This configuration is not that good because there are drawbacks using this kind of configuration. Because all the routes learned in EIGRP is place in the BGP table in which in some cases this is unacceptable. There are routes in EIGRP that you might not consider to be part of your BGP table. Another reason is the problem of route feedback, when using redistribution the route feedback is always a possibility in your network. Because of this you must apply route policies to compensate the
situation.

Below is another configuration of injecting IGP routes into BGP.

router eigrp 200
passive-interface s0
network 192.168.1.0
network 192.168.100.0
!
router BGP 200
network 192.168.1.216 mask 255.255.255.252
network 192.168.100.0
network 192.168.200.0
neighbor 192.168.1.226 remote-as 100

As you observe in the BGP process, that a network command replaced the
redistribution command. This is better way than redistributing because you
had fully control on the networks that you want to include in your BGP table.

Advertisements

7 Responses

Subscribe to comments with RSS.

  1. Nick Knatt said, on October 12, 2008 at 9:22 am

    hello ! so far so good !
    i am experiencing a situation, where a perticular EIGRP route is also injected into BGP elsewhere into the network, making that other route more preferable because of BGP lower admin distance. how can i force the EIGRP route not only to be preferred in that specific router but also being advertised out thru BGP from there ? it seems that the box likes BGP routes much more than EIGRP ones :-). route-maps dont allow setting admin distance in EIGRP process, the distance bgp 20 200 19 command in the bgp process did not help.
    manipulating the route’s local preference in the bgp network statement also did not make the box switch to eigrp preference.
    IOS version: C3725-IS-M, Version 12.3(26)

    any ideas ?
    much apprechiated,
    Nick

  2. edeguzman said, on October 26, 2008 at 12:05 am

    Hi, sorry for the late reply. From the way I picture out your problem is that you are experiencing two the same routes that is coming from the EIGRP and the other from BGP. But the BGP route was preferred rather than from EIGRP route? From your statements I can sense that your talking about external EIGRP and external BGP ? External BGP has a lower BGP AD than the EIGRP AD so it means that BGP routes will always be preferred. If you change the EIGRP AD into 10, the EIGRP route should be preferred because BGP AS is 20 (by default). Or try changing BGP AD using this cisco command distance bgp 200 200 20. You told me earlier that you use that command distance bgp 20 200 19, distance bgp command is defined as distance bgp (external) (internal) (local route) , the external AS was still 20 that’s why BGP routes will still be preferred in its process.

    Furthermore you also told me that you had injected the EIGRP route into BGP? So I’m thinking that you had redistributed the EIGRP route into BGP. From doing it, the EIGRP route became part of BGP routes in which you should be seeing in BGP table. It will have origin attribute value of INCOMPLETE. Naturally that route will not be preferred if there exist the same route entry that was originated in BGP. That’s the reason why that redistributed route will not be advertise out in BGP instead the other route (route originated in BGP) is being advertised. There’s always a route selection process in BGP that is based on hierarchy.

    That would be all….

  3. RaiulBaztepo said, on March 31, 2009 at 2:34 am

    Hello!
    Very Interesting post! Thank you for such interesting resource!
    PS: Sorry for my bad english, I’v just started to learn this language 😉
    See you!
    Your, Raiul Baztepo

  4. PiterKokoniz said, on April 8, 2009 at 12:54 pm

    Hi !!! 🙂
    My name is Piter Kokoniz. Just want to tell, that I’v found your blog very interesting
    And want to ask you: is this blog your hobby?
    Sorry for my bad english:)
    Thank you:)
    Piter.

  5. edeguzman said, on January 29, 2010 at 10:04 am

    Hi guys,

    Hope my blog serves as an useful resource for you. I’m just here to share my knowledge.
    And yes this would be probably my hobby.

    cheers,

  6. Sohan said, on December 16, 2011 at 10:01 am

    it is very interesting post.

  7. Kal said, on May 29, 2013 at 5:40 am

    Very clear! Thanks..


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: