BGP feature’s configuration

Posted in NETWORKING/IP ROUTING by edeguzman on October 6, 2007

Neighbor description – can be entered under an interface configuration. This is helpful because when the BGP configuration is already elaborate, this will serve you a reminder of who and where each neighbor. Can obtain to 80 characters.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 description ———–T1 to mynetwork.

Neighbor Password – two peers can have an authentication with password. Cisco IOS uses MD5 authentication when a neighbor password is configured.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 password

Neighbor advertisement-interval – this will change the default BGP update interval to a specified between 0 and 600 seconds. But this is not advisable to change the default unless you know the consequences. This is useful when there is large updates receiving in the neighbor. Convergence time will greatly affect changing this time.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 advertisement-interval

Neighbor version – when a neighboring peer cannot support the BGP-4. This command will negotiate to have its version be lower to compensate the version of the other peer.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 version

Neighbor maximum-prefix – this will limit the number of prefixes that a router will receive fro the neighboring peer. If the limit is exceeded then router closes the BGP session and cannot re-established its peer.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 maximum-prefix

Another config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 maximum-prefix 90 warning-only
This configuration will not close the BGP session but instead it will cause the router to generate log message. When the 90% of the maximum-prefix was reached it will then cause to log a message.

Neighbor shutdown – this will shutdown the neighbor connection in that sense there will be no TCP connection between the neighbor. This is useful when you only want to temporarily disconnect your peer.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 shutdown

Timers bgp – this command will change the default time for keepalive and holddown intervals. The default time interval for keepalive is 60 seconds and holddown interval is 180 seconds. This command is useful if you want a fast detection of the unreliable peer. This command is necessary configured to every peer in the AS. Because there is still negotiation occur on the process of building an established state of the peer.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Timer bgp

When there is changes done to BGP process, a reset connection is must be done to be able have an update BGP route that is affected by the changes in the BGP process. Below are the useful commands for resetting the BGP connection.

Clear ip bgp * – this command is issue in the privileged mode. This command will reset all of the router’s BGP connections.

Clear ip bgp 192.168.1.253 – this command will reset connection to the neighbor 192.168.1.253.

Clear ip bgp mygroup – this command will reset the connection to all members of the peer group name mygroup.

Note:
Resetting a connection will cause a Cease notification be sent to the neighbor. In that sense the TCP connection is closed and BGP routes will be then a withdrawn routes. A new BGP connection will be then be established. Resetting the whole connection will cause a serious consequences to the network. Reset only the affected neighbor to avoid possible problems in the network.

Cisco provides another way in resetting the connections. This alternative way will not tear down the TCP and BGP connection. This command will only cause a trigger update for the affected changes. Triggered update for this command can happened for outbound, inbound or both. Outbound is the out going traffic while the inbound is the incoming traffic. Below is the sample config.

Clear ip bgp 192.168.2.253 soft out – if you done a changes in your BGP process and the neighbor 192.168.2.253 is affected to the changes you made, use this command to cause and trigger update for that neighbor. This is an outbound type.

The configuration for inbound is different thing, because you need to configured in the BGP process the command neighbor x.x.x.x soft-configuration inbound before inbound command is used. Take not inbound is used when you done changes to your BGP process that affects the incoming traffic. The command clear ip bgp soft in is then used for every neighbor that is affected in the changes. For both inbound and outbound the command clear ip bgp x.x.x.x soft.

Note:
There is a drawback for using the soft reconfiguration, it uses a router’s memory to stored its updates for the inbound.

Next-hop and fully-meshed configuration

Posted in NETWORKING/IP ROUTING by edeguzman on October 3, 2007

VailV4#sh run
Building configuration…

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname VailV4
!
enable secret 5 $1$OiVL$E8vhRllZnn3MFwXkecM2I1
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
ip host tahoe 192.168.1.210
ip host taos 192.168.1.225
ip host aspen 192.168.1.222
!
lane client flush
!
!
!
!
!
!
!
interface Ethernet0/0
ip address 192.168.1.221 255.255.255.252
!
interface Ethernet0/1
no ip address
shutdown
!
interface Serial1/0
ip address 192.168.1.226 255.255.255.252
no fair-queue
clockrate 64000
!
interface Serial1/1
ip address 192.168.1.209 255.255.255.252
clockrate 64000
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
router bgp 100
no synchronization
network 192.168.1.208 mask 255.255.255.252
network 192.168.1.224 mask 255.255.255.252
neighbor 192.168.1.197 remote-as 100
neighbor 192.168.1.197 next-hop-self
neighbor 192.168.1.210 remote-as 300
neighbor 192.168.1.222 remote-as 100
neighbor 192.168.1.222 next-hop-self
neighbor 192.168.1.225 remote-as 200
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password passkey
login
!
end

VailV4#

This configuration shows that the router vail was set up as a next-hop self. Wherein it simply means that the next_hop attribute for every update that it will send to the routers within the AS.

The configuration also shows that it is configured in fully meshed because the router
is configured as neighbor in every router in the AS.

As you also observed that there is a no synchronization configured in the BGP routing process. This is one tough stuff that I find it quite confusing until I grasp the concept on it. In CISCO routers the by default they are configured as synchronization, in that sense before a route learned from an IBGP neighbor is entered into the IGP routing table or before it is being advertised to a BGP peer, the route must be first be known via its IGP. The running IGP in the AS will track every posible route to the AS, in that sense a router with in the AS must know the route going to the destination before the
route will be place in the routing table.. Now when there is no synchronization, the routes in the BGP table will be place to the routing table even if the path going to the destination is unknown, that’s why fully meshed must be configured and all networks and subnets connecting to the IBGP routers must be known.