Aggregating Routes on BGP

Posted in NETWORKING/IP ROUTING by edeguzman on October 3, 2007

This configuration shows the different ways of advertsing an aggregate routes to a peer. This configuration is placed in a border gateway of a AS. Below is the basic configuration on the applying of the aggregate route.

router eigrp 100
!
network 192.168.199.0
!
router bgp 100
network 192.168.192.0 mask 255.255.248.0
neighbor 192.168.1.253 remote-as 200
!
ip route 192.168.192.0 255.255.248.0 Null0

The network 192.168.192.0 mask 255.255.248.0 simply advertise the aggregate route to its peer. There is also a static entry in the configuration which its pointing to a Null0, this will static entry simply serve as black hole for the border gateway. Whenever a route matches the aggregate address 192.168.192.0 (take note that this 192.168.192.0 is the more-specific route in the border gateway’s routing table, so this will be the basis for summarization or aggregation of every route passing to the border gateway) it will be forwarded to the border gateway and the border gateway will check to its routing table the more-specific address that will match the route. If there is a match it will forward the packet to the destination but if there’s no match for the route then the route will be match to the static entry and this will go to the Null0 to be drop.

Below is another way of doing the aggregation.

router eigrp 100
passive-interface Serial0/0
network 192.168.199.0
no auto-summary
!
router bgp 100
bgp log-neighbor-changes
aggregate-address 192.168.192.0 255.255.248.0 summary-only
redistribute eigrp 100
neighbor 192.168.1.253 remote-as 200
!

aggregate-address 192.168.192.0 255.255.248.0 summary-only this command will advertise a aggregate address to its peer. The summary-only command makes the other routes suppressed, only the aggregate address is being advertised to its peer.

Injecting IGP routes into BGP

Posted in NETWORKING/IP ROUTING by edeguzman on October 3, 2007

This is a configuration wherein routes in the routing table is place in the BGP table.
The routes in the BGP table will be advertised to its BGP peer whether its inter-AS or
intra-AS. Below is the configuration.

router eigrp 200
passive-interface s0
network 192.168.1.0
network 192.168.100.0
!
router bgp 200
redistribute eigrp 200
neighbor 192.168.1.226 remote-as 100
!

The configuration shows that I used the EIGRP as my IGP running within the AS 200,
a passive-interface is configured in its process, wherein it means that in the interface serial 0 it will not advertise neither receives updates and it will not even send a hello packet in that interface.

In the BGP process, a redistribute eigrp 200 is configured this will simply redistribute the routes learned via EIGRP into the BGP table. You can see its results by making a show ip bgp, from there you can see the routes of EIGRP that is distributed into the BGP table. This configuration is not that good because there are drawbacks using this kind of configuration. Because all the routes learned in EIGRP is place in the BGP table in which in some cases this is unacceptable. There are routes in EIGRP that you might not consider to be part of your BGP table. Another reason is the problem of route feedback, when using redistribution the route feedback is always a possibility in your network. Because of this you must apply route policies to compensate the
situation.

Below is another configuration of injecting IGP routes into BGP.

router eigrp 200
passive-interface s0
network 192.168.1.0
network 192.168.100.0
!
router BGP 200
network 192.168.1.216 mask 255.255.255.252
network 192.168.100.0
network 192.168.200.0
neighbor 192.168.1.226 remote-as 100

As you observe in the BGP process, that a network command replaced the
redistribution command. This is better way than redistributing because you
had fully control on the networks that you want to include in your BGP table.

IBGP over IGP

Posted in NETWORKING/IP ROUTING by edeguzman on October 3, 2007

This configuration is one of the router within the AS 100. Basically on the laboratory there are 3 routers present within the AS. Two routers serve as the Border Gateway, each of them runs a BGP process and at the same time an OSPF process runs as its IGP. One of the Border Gateway is connected to a stub AS and the other Border Gateway is connected by two stub AS. The other router within the AS just runs an OSPF connecting the two Border Gateway.

Below is the configuration of one of the border gateway.

interface Loopback0
ip address 192.168.255.254 255.255.255.255
!
interface Ethernet0/0
ip address 192.168.1.221 255.255.255.252
!
interface Ethernet0/1
ip address 192.168.1.193 255.255.255.252
!
interface Serial1/0
ip address 192.168.1.226 255.255.255.252
no fair-queue
clockrate 64000
!
interface Serial1/1
ip address 192.168.1.209 255.255.255.252
clockrate 64000
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
router ospf 100
redistribute bgp 100 subnets
network 192.168.1.193 0.0.0.0 area 0
network 192.168.1.221 0.0.0.0 area 0
network 192.168.255.254 0.0.0.0 area 0
!
router bgp 100
timers bgp 3 9
neighbor 192.168.1.210 remote-as 300
neighbor 192.168.1.210 default-originate
neighbor 192.168.1.225 remote-as 200
neighbor 192.168.255.253 remote-as 100
neighbor 192.168.255.253 update-source Loopback0
neighbor 192.168.255.253 next-hop-self
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
password passkey
login
!
end

Neighbor 192.168.255.253 update-source Loopback0 – this command simply causes the BGP messages to be sourced from the IP address of the loopback interface rather than from the physical interface. Without this command, the TCP source of the TCP sessions would be the outgoing interface and not the loopback interface.

timers bgp 3 9 – this command basically change the time of the keepalive message
being send to a peer and the holddown time. 3 is the keepalive message and 9 is the holddown time.

neighbor 192.168.1.210 default-originate – this command simply advertise a default-
route to the neighboring peer.

The other commands are already explained from my previous post. I got heavy day thats why I felt tired. This one is quick post in one of configuration I did for the day.

BGP routes into IGP

Posted in NETWORKING/IP ROUTING by edeguzman on September 29, 2007

This is the configuration that I’d done during in our laboratory regarding on Border Gateway Protocol (BGP). Basically this configuration will give you an BGP routes be a part of the IGP route. Of course this configuration is configured in the Border Gateway of Autonomous System (AS). Below is the configuration, I will try to explain every details of the configuration.

router eigrp 200
redistribute bgp metric 10000 100 255 1 1500
passive-interface Serial0/0
network 192.168.1.0
network 192.168.100.0
network 192.168.214.0
no auto-summary
!
router bgp 200
bgp log-neighbor-changes
network 192.168.1.216 mask 255.255.255.252
network 192.168.100.0
network 192.168.200.0
neighbor 192.168.1.226 remote-as 100
!

Within the AS 200, the EIGRP is the IGP that runs within the AS. The router BGP runs in the AS, You must be aware that this BGP is the one responsible for communicating inter-AS, although there are other ways to do the inter-AS communication but still the BGP is the best choice. Choices like redistribution is not good enough b’coz it provides alot deficiency just like route feedback. But I’m not going to promote BGP hehe it always still depends on the kind of networks you are running.

The redistribute bgp metric 10000 100 255 1 1500 in the EIGRP process is the key points in injecting BGP routes into an IGP. Basically, the routes in the BGPtable is being redistributed into the IGP tables. One important point to consider whendoing the redistribution is metric of the IGP being used in the domain. Just like in my configuration whereas I’d used the EIGRP as my IGP within the domain.

You need totake note of the metric of the routing protocols, like EIGRP wherein it uses bandwidth,delay, realibility, load and MTU that’s why bandwidth=10000, delay=100, realibility=255,load=1 and MTU=1500 in my configuration. To verify that routes from BGP is successfully injected to the IGP routes. Check the routing table of the routers within the AS and compare it to the BGP table in the border gateway.