BGP feature’s configuration

Posted in NETWORKING/IP ROUTING by edeguzman on October 6, 2007

Neighbor description – can be entered under an interface configuration. This is helpful because when the BGP configuration is already elaborate, this will serve you a reminder of who and where each neighbor. Can obtain to 80 characters.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 description ———–T1 to mynetwork.

Neighbor Password – two peers can have an authentication with password. Cisco IOS uses MD5 authentication when a neighbor password is configured.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 password

Neighbor advertisement-interval – this will change the default BGP update interval to a specified between 0 and 600 seconds. But this is not advisable to change the default unless you know the consequences. This is useful when there is large updates receiving in the neighbor. Convergence time will greatly affect changing this time.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 advertisement-interval

Neighbor version – when a neighboring peer cannot support the BGP-4. This command will negotiate to have its version be lower to compensate the version of the other peer.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 version

Neighbor maximum-prefix – this will limit the number of prefixes that a router will receive fro the neighboring peer. If the limit is exceeded then router closes the BGP session and cannot re-established its peer.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 maximum-prefix

Another config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 maximum-prefix 90 warning-only
This configuration will not close the BGP session but instead it will cause the router to generate log message. When the 90% of the maximum-prefix was reached it will then cause to log a message.

Neighbor shutdown – this will shutdown the neighbor connection in that sense there will be no TCP connection between the neighbor. This is useful when you only want to temporarily disconnect your peer.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Neighbor 192.168.1.1 shutdown

Timers bgp – this command will change the default time for keepalive and holddown intervals. The default time interval for keepalive is 60 seconds and holddown interval is 180 seconds. This command is useful if you want a fast detection of the unreliable peer. This command is necessary configured to every peer in the AS. Because there is still negotiation occur on the process of building an established state of the peer.

Sample config:
Neighbor 192.168.1.1 remote-as 500
Timer bgp

When there is changes done to BGP process, a reset connection is must be done to be able have an update BGP route that is affected by the changes in the BGP process. Below are the useful commands for resetting the BGP connection.

Clear ip bgp * – this command is issue in the privileged mode. This command will reset all of the router’s BGP connections.

Clear ip bgp 192.168.1.253 – this command will reset connection to the neighbor 192.168.1.253.

Clear ip bgp mygroup – this command will reset the connection to all members of the peer group name mygroup.

Note:
Resetting a connection will cause a Cease notification be sent to the neighbor. In that sense the TCP connection is closed and BGP routes will be then a withdrawn routes. A new BGP connection will be then be established. Resetting the whole connection will cause a serious consequences to the network. Reset only the affected neighbor to avoid possible problems in the network.

Cisco provides another way in resetting the connections. This alternative way will not tear down the TCP and BGP connection. This command will only cause a trigger update for the affected changes. Triggered update for this command can happened for outbound, inbound or both. Outbound is the out going traffic while the inbound is the incoming traffic. Below is the sample config.

Clear ip bgp 192.168.2.253 soft out – if you done a changes in your BGP process and the neighbor 192.168.2.253 is affected to the changes you made, use this command to cause and trigger update for that neighbor. This is an outbound type.

The configuration for inbound is different thing, because you need to configured in the BGP process the command neighbor x.x.x.x soft-configuration inbound before inbound command is used. Take not inbound is used when you done changes to your BGP process that affects the incoming traffic. The command clear ip bgp soft in is then used for every neighbor that is affected in the changes. For both inbound and outbound the command clear ip bgp x.x.x.x soft.

Note:
There is a drawback for using the soft reconfiguration, it uses a router’s memory to stored its updates for the inbound.

Aggregating Routes on BGP

Posted in NETWORKING/IP ROUTING by edeguzman on October 3, 2007

This configuration shows the different ways of advertsing an aggregate routes to a peer. This configuration is placed in a border gateway of a AS. Below is the basic configuration on the applying of the aggregate route.

router eigrp 100
!
network 192.168.199.0
!
router bgp 100
network 192.168.192.0 mask 255.255.248.0
neighbor 192.168.1.253 remote-as 200
!
ip route 192.168.192.0 255.255.248.0 Null0

The network 192.168.192.0 mask 255.255.248.0 simply advertise the aggregate route to its peer. There is also a static entry in the configuration which its pointing to a Null0, this will static entry simply serve as black hole for the border gateway. Whenever a route matches the aggregate address 192.168.192.0 (take note that this 192.168.192.0 is the more-specific route in the border gateway’s routing table, so this will be the basis for summarization or aggregation of every route passing to the border gateway) it will be forwarded to the border gateway and the border gateway will check to its routing table the more-specific address that will match the route. If there is a match it will forward the packet to the destination but if there’s no match for the route then the route will be match to the static entry and this will go to the Null0 to be drop.

Below is another way of doing the aggregation.

router eigrp 100
passive-interface Serial0/0
network 192.168.199.0
no auto-summary
!
router bgp 100
bgp log-neighbor-changes
aggregate-address 192.168.192.0 255.255.248.0 summary-only
redistribute eigrp 100
neighbor 192.168.1.253 remote-as 200
!

aggregate-address 192.168.192.0 255.255.248.0 summary-only this command will advertise a aggregate address to its peer. The summary-only command makes the other routes suppressed, only the aggregate address is being advertised to its peer.

BGP routes into IGP

Posted in NETWORKING/IP ROUTING by edeguzman on September 29, 2007

This is the configuration that I’d done during in our laboratory regarding on Border Gateway Protocol (BGP). Basically this configuration will give you an BGP routes be a part of the IGP route. Of course this configuration is configured in the Border Gateway of Autonomous System (AS). Below is the configuration, I will try to explain every details of the configuration.

router eigrp 200
redistribute bgp metric 10000 100 255 1 1500
passive-interface Serial0/0
network 192.168.1.0
network 192.168.100.0
network 192.168.214.0
no auto-summary
!
router bgp 200
bgp log-neighbor-changes
network 192.168.1.216 mask 255.255.255.252
network 192.168.100.0
network 192.168.200.0
neighbor 192.168.1.226 remote-as 100
!

Within the AS 200, the EIGRP is the IGP that runs within the AS. The router BGP runs in the AS, You must be aware that this BGP is the one responsible for communicating inter-AS, although there are other ways to do the inter-AS communication but still the BGP is the best choice. Choices like redistribution is not good enough b’coz it provides alot deficiency just like route feedback. But I’m not going to promote BGP hehe it always still depends on the kind of networks you are running.

The redistribute bgp metric 10000 100 255 1 1500 in the EIGRP process is the key points in injecting BGP routes into an IGP. Basically, the routes in the BGPtable is being redistributed into the IGP tables. One important point to consider whendoing the redistribution is metric of the IGP being used in the domain. Just like in my configuration whereas I’d used the EIGRP as my IGP within the domain.

You need totake note of the metric of the routing protocols, like EIGRP wherein it uses bandwidth,delay, realibility, load and MTU that’s why bandwidth=10000, delay=100, realibility=255,load=1 and MTU=1500 in my configuration. To verify that routes from BGP is successfully injected to the IGP routes. Check the routing table of the routers within the AS and compare it to the BGP table in the border gateway.